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Conventions Used in this Guide
In this user guide, the following are used:

NOTE:	 A note draws attention to important information.

TIP:	 A tip provides a suggestion to make setting up or working with the software easier.

Selectable items, such as menu names, menu options, buttons, tabs, and field names are 
written in the font shown here:

From the File menu, select New.

Click the OK button.
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Introduction and 
Installation

This section gives an overview of the guide and features of the Extron JPEG 2000 Encoder 
software. Installation is also described. Topics that are covered include:

zz About this Guide

zz About the JPEG 2000 Encoder

zz System Requirements

zz Software Installation

About this Guide
This guide provides detailed information about the JPEG 2000 Encoder software, including 
software installation and encoding procedure. In this guide, “J2KENC” refers to the 
lite version of JPEG 2000 Encoder and “J2KENC-PRO” refers to the full version. Notes 
distinguish where the two versions differ. 

About the JPEG 2000 Encoder
The Extron JPEG 2000 Encoder is available in two versions on the disc that is shipped with 
the JMP 9600 JPEG 2000 Media Player. These two versions are:

zz JPEG 2000 Encoder “Lite” — Provided free of charge to all purchasers of the  
JMP 9600. This version is the default when the JPEG 2000 Encoder software is first 
installed on your encoding computer. The application has basic functionality powerful 
enough for situations that require encoding short clips with a single audio (stereo) file.

zz JPEG 2000 Encoder “Full” — When the license and activation key are received from 
Extron, all functionality of the full version is enabled without further software installation 
(the full version is loaded as part of the initial installation on the encoding computer but 
is disabled until licensed).

The software runs on Microsoft® Windows® 7 or Windows XP operating systems and 
allows you to prepare content for playback on the JMP 9600 without the need for external 
encoding services. It constructs visually lossless MXF wrapped Digital Cinema Package (DCP) 
files. The DCP includes video, audio, and other associated data encoded to comply with the 
DCI (Digital Cinema Initiatives, LLC) requirements for unencrypted content. The DCPs that 
are generated by the JPEG 2000 Encoder are subsequently transferred to the JMP 9600 for 
playback.
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As the time required for encoding a DCP is directly proportional to the number of image 
frames and the size of the associated audio files, the full version software is tailored to use 
all of the processing power of the encoding computer (see “System Requirements”). 
The application can run simultaneously on multiple computers, thereby functioning as an 
“encoding array” to significantly increase throughput when processing DCPs. The difference 
in processing speed between the two versions is considerable.

NOTES:	 •	 Using the lite version for encoding large video clips can take many hours or 
days.

•	 The lite version supports only a single thread (computer processor core), even if 
the computer is multi-threaded, and a single stereo audio input.

Features

Lite version 

zz Outputs unencrypted JPEG 2000 encoded video (encapsulated in DCPs) for playback on 
the JMP 9600

zz Runs on a Microsoft Windows computer platform (see “System Requirements”)

zz Works on a single computer

zz Image encoding for BMP, DPX, TGA (24 bpp [bits per pixel] and 32 bpp only), and TIFF 
file formats. Extron recommends using TIFF format.

zz Facilities to MXF wrap uncompressed 24-bit Broadcast WAV files

zz Supports a variety of video output parameters (such as format, colorspace, and 
compression rate)

zz Status of the encoding process is tracked through to completion

Full version

zz Outputs unencrypted JPEG 2000 encoded video (encapsulated in DCPs) for playback on 
the JMP 9600

zz Supports a number of editing features including text overlay, timecode stamp, image 
crop, image letterbox, and letterbox position within the output frame

zz Supports batch encoding

zz Runs on a Windows computer platform (see “System Requirements”)

zz Adjustable to the number of threads (computer processor cores) available

zz Works in parallel on multiple computers (encoding array)

zz Image encoding for BMP, DPX, TGA (24 bpp and 32 bpp only), and TIFF file formats. 
Extron recommends using TIFF format.

zz Facilities to MXF wrap uncompressed 24-bit Broadcast WAV files (up to 16 channels)

zz Facilities to interleave multiple mono WAV files into a single, multi-channel WAV file

zz Supports a variety of video output parameters (such as format, colorspace, and 
compression rate)

zz Status of the encoding process is tracked through to completion
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System Requirements
Ensure that the system hardware to be used meets or exceeds the minimum requirements 
listed below. Encoding performance improves when a system more powerful than the 
minimum listed here is incorporated.

NOTES:	 •	 The encoding computers must be network capable.

•	 It is recommended that the application be used on a computer with superior 
processing capacity, speed, and memory to reduce encoding time since the 
process can take hours (or days), depending on the length of the video.

Minimum system requirements:

zz Intel® Pentium® 4, 2.8 Ghz (1 core)

zz 2 GB RAM

zz Windows XP SP3

zz Microsoft .NET Framework 3.5 SP1

zz 1 GB of available hard disk space on the system drive

5 GB or more is recommended on the installation drive and 20 percent free space on the 
media drive (see the note below) for encoding temporary files (this value depends on 
encoder compression rate).

NOTE:	 The Media drive is the hard disk drive on the local computer reserved for 
DCP output.

zz Typical encoding performance: 0.2 frames per second

Recommended system:

zz Intel® Core™ i5, 3.4 Ghz (2 cores, 4 threads) or better

zz 4 GB RAM

zz Windows 7 64-bit

zz Microsoft .NET Framework 3.5 SP1

zz 1 GB of available hard disk space on the system drive

5 GB or more is recommended on the installation drive and 20 percent free space on the 
media drive (see the note below) for encoding temporary files (this value depends on 
encoder compression rate).

NOTE:	 The Media drive is the hard disk drive on the local computer reserved for 
DCP output.

zz Typical encoding performance: 6.0 frames per second

NOTE:	 It is recommended that a monitor supporting the encoded resolution and 
frame rate be used. This is beneficial for production and quality control after 
encoding.
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Software Installation
The JPEG 2000 Encoder application requires Microsoft .NET Framework 3.5 SP1 in order 
to function. Ensure that your encoding computer is equipped with this version of .NET 
Framework before installing the JPEG 2000 Software Encoder.

To verify or install .NET Framework:

1.	 Verify the presence (or absence) of Microsoft .NET Framework 3.5 SP1.

If using Windows XP: 
From the desktop, navigate to Start > Control Panel > Add or Remove 
Programs and verify the presence (or absence) of Microsoft .NET Framework 3.5 SP1.

If using Windows 7: 
From the navigate to Start > Control Panel > Programs and Features > Turn 
Windows Features On or Off and verify the presence (or absence) of  
Microsoft .NET Framework 3.5 SP1.

2.	 If Microsoft .NET Framework 3.5 SP1 is present, exit the current screen and continue to 
the JPEG 2000 Encoder installation steps. 
- or - 
If it is not present or if an earlier version of .NET (versions 1 through 3) is installed:

a.	 Open the web browser and in the Address field, enter http://download.
microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/
dotnetfx35.exe.

b.	 Download Microsoft .NET Framework 3.5 SP1 from the website.

c.	 Install the downloaded application on the encoding computer.

JPEG 2000 Encoder • Introduction and Installation 4

http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe
http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe
http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe


To install the JPEG 2000 Encoder:

Steps 3 and 4 are shown in figure 1.

1.	 Load the JPEG 2000 Encoder installation file on your encoding computer.

2.	 On-screen instructions appear, starting the installation setup of the JPEG 2000 Encoder. 
Click Next.

3.	 On the Select Installation Folder screen, click Browse to navigate to a different folder in 
which to install the application If desired and click Disk Cost to check available disk 
space.  

Figure 1.	 Select Installation Folder Screen 

4.	 Select whether to install the JPEG 2000 Encoder for yourself or for everyone using this 
computer.

5.	 Click Next. 

6.	 On the License Agreement screen, read the license agreement and select I Agree to 
continue.

7.	 On the Confirm Installation screen, click Next to start the installation.

8.	 When installation is complete, click Close. 

9.	 Verify the storage locations of the video and audio data on the network. 
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To open the JPEG 2000 Encoder:

Double-click the JPEG 2000 Encoder icon on your desktop.   
- or -  
From the desktop, click Start > All Programs > Extron Electronics > JPEG 
2000 Encoder.

The default lite version of the application opens. 

Figure 2.	 Indication of Lite or Full Version of JPEG 2000 Encoder

You can use the lite version of the application immediately (without access to its full feature 
set) or you can choose to activate the full version of the software.

Licensing and Activating the Full Version

Skip this process if you have not purchased the full version of the software. 

To verify the software version being used: 

1.	 From the Help menu, select About JPEG 2000 Encoder. The About dialog box opens.

Figure 3.	 About Screen

2.	 Click OK to close the screen and return to the main screen of the application.
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To license and activate the full version:

Some of the steps are shown in figure 4.

1.	 Contact Extron for a full license and to generate the license and activation keys. You will 
receive a license key from Extron via e-mail.

2.	 From the Help menu, select Licensing and Activation. The Licensing and 
Activation screen opens.   

Figure 4.	 Licensing and Activation Screen

3.	 Copy and paste the license key characters into the License Key field.

NOTE:	 The hyphens in the license key are necessary when you are entering the 
information into the field.

4.	 Click Get to obtain seed information. This text appears in the Seed section of the 
Licensing and Activation screen.

5.	 Copy the seed information (there are multiple lines of characters) from the Seed section 
of the screen and paste it in a reply e-mail to Extron.

6.	 Send the e-mail containing the seed information to Extron.

7.	 In response, you receive the activation key from Extron via e-mail. Copy and paste it into 
the Activation Key field of the Licensing and Activation screen.

NOTE:	 The hyphens in the activation key are necessary when you are entering the 
information into the field.

8.	 Click Activate. A dialog box opens confirming the activation.

9.	 Click OK in the dialog box.

10.	Click OK to exit the screen. You are now ready to encode media for the JMP 9600.
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Transferring a license to a different PC

Follow the steps below to transfer the full license to another computer if needed. You can 
also use this procedure to transfer the full license back to the original computer if needed.

1.	 From the Help menu, select Licensing and Activation. The Licensing and 
Activation screen opens. Make a note of the original license key.

2.	 Click Transfer Code. A transfer code is generated and the original PC now has the lite 
version of the JPEG 2000 Encoder. Make a note of this transfer code.

3.	 With the JPEG 2000 Encoder open on the new PC, enter the old license key into the 
License Key field of the Licensing and Activation screen.

4.	 Click Get to obtain seed information. This text appears in the Seed section.

5.	 Copy and paste the old license key, the transfer code you obtained on the original PC, 
and the new PC seed information into an e-mail to Extron. 

6.	 Send the e-mail. 

7.	 In response, you receive a new activation code for the new PC via e-mail. Copy and 
paste it into the Activation Key field of the Licensing and Activation screen.

8.	 Click Activate. A dialog box opens confirming the activation.

9.	 Click OK in the dialog box.

10.	Click OK to exit the Licensing and Activation screen.
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Encoding 
Procedure

This section describes the process of encoding content for the JMP 9600. Topics that are 
covered include:

zz Encoding Overview

zz Main Menu Options

zz Single Clip Encoding

zz Batch Encoding

zz Status Indication

zz Encoding Across Multiple Computers (Remote Machines)

Encoding Overview
The main steps for encoding content for the JMP 9600 are as follows:

1.	 Check that the hardware profile matches the player type for which you are encoding 
content (see “JMP 9600 Hardware Profile”). 

2.	 From the Tasks menu, select Encode to open the Encode Settings screen (see “Tasks 
Menu”).

3.	 Select the input data to be encoded (such as image frames and audio files) (see 
“Inputs”).

4.	 Set the encoding parameters (see “Encoding parameters”).

5.	 Add remote machines to function as an encoding array (optional for full version)  
(see “Encoding Across Multiple Computers [Remote Machines]”).

6.	 Name the DCP and choose a storage location on the local disk drive for the final output 
(see “Outputs”).

7.	 Perform any editing tasks (see “Effect Settings tab“ and “Drawing Settings tab”).

8.	 Encode the content (see “Single Clip Encoding“ and “Batch Encoding”).

NOTES:	 •	 The source data for encoding as well as the resultant output DCP resides on 
the local computer even if an encoding array is employed, unless the input 
path, output path, or both is a remote machine mapped on the network. 

•	 Ensure that frame file names that include a numerical component use the 
same number of digits in all file names.

Main Menu Options
The options available through the menu bar of the JPEG 2000 Encoder are used to access 
certain configuration settings. Modify these settings as needed before beginning an 
encoding session.
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File Menu

From the File menu, select Exit to close the application. You can also click the  in the 
upper right corner of the application window to close the JPEG 2000 Encoder.

Tasks Menu

The Encode option is used to configure the application to find source files (video and audio 
inputs), set encoding parameters, edit the frames, define output names, and define the 
output location.

NOTE:	 If you are using multiple machines, use mapped drives rather than relative paths 
for the locations of source and output data.

To access the encoding settings:

From the Tasks menu, select Encode. The Encode Settings tab of the Encode 
Settings screen opens.   

Figure 5.	 Encode Settings Tab

On this screen, you can:

zz Select the Encode Settings tab to configure the application for the session.

zz Select the Effect Settings tab to access image format (size) editing features.

zz Select the Drawing Settings tab to access text overlay, editing features, and the 
timecode stamp.

You can also open the Encode Settings screen by double-clicking an item in the Composition 
column of the JPEG 2000 Encoder main screen.
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Encode Settings tab

Loading or saving encode settings

You can save your encoding configuration settings as an EPR file that can be reused at a later 
time. The configuration settings that are saved include encoding settings, effect settings, 
and drawing settings.

To save a configuration:

1.	 From the Tasks menu, select Encode.

2.	 On the Encode Settings tab, adjust the encoding settings as desired.

NOTE:	 An output folder needs to be specified in order to save the encoding settings 
(see “Outputs”).

3.	 Click the  button in the upper right corner of the Encoding Settings tab. The 
Save As dialog box opens.

4.	 Navigate to a folder in which to store the file.

5.	 In the File name field, enter a name for the file.

6.	 Click Save.

To retrieve a previously saved configuration:

1.	 From the Tasks menu, select Encode.

2.	 On the Encode Settings tab, click the  button. The Open dialog box is displayed.

3.	 Navigate to and select the desired EPR file.

4.	 Click Open. This loads the saved encoding settings.

Inputs

The Inputs section of the Encode Settings tab allows you to let the encoder know where 
to look for the frames (graphics files) to be encoded.

To adjust video settings:

1.	 From the Tasks menu, select Encode.

2.	 Select the Encode Settings tab.

3.	 Below the Video Folder field of the Inputs section, select either Multiple Frames or 
Single Frame to define the type of encoding desired. 

NOTE:	 If Multiple Frames is selected, this field is called Video Folder. If 
Single Frame is selected, this field is called Frame Path.

Single Frame encoding allows the producer to generate a video clip (DCP package) with 
a specified length (number of frames) from a single graphics file in one of the supported 
formats. 

TIP:	 If corresponding audio is required, the audio tracks should be trimmed to the 
number of samples matching the length of the video.

4.	 If Single Frame is selected, enter the number of frames to be generated from the 
single frame in the Frames field. The Frames field is located beside the Frame Path 
field when Single Frame is selected.
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5.	 Beside the Video Folder field, click the  button to navigate to the folder (or 
the previously mapped drive) containing sequential image frames (BMP, DPX, TGA, or 
TIFF) that are to be encoded (Extron recommends using TIFF format). The path for the 
selected folder appears in the Video Folder field.

NOTES:	 •	 When selecting and opening a folder in the Browse for Folder dialog box, 
the files within the folder are not displayed. 

•	 All of the image files in this folder are included in the encoding process. 
Ensure that only the required files are placed in the selected folder. Audio 
files or files of a different type are not encoded.

TIPS:      •  The encoder processes image files with 8 bits per color channel, but use 
of source material with a bit depth as low as this may result in visible 
contours in areas of the image with subtle graduation (for example, 
clouds).

•	 The files should be located on a local drive for better performance.

•	 For best results, use uncompressed, progressive file formats with the 
highest bit depth. Uncompressed TIFF files with 16 bits per color channel 
are ideal. DPX files with 10 bits per color channel are the next best option.

You can also adjust the settings for audio sources in the Inputs section of the Encode 
Settings tab.

NOTES:	 •	 The JMP 9600 JPEG 2000 Media Player supports encoding only even pairs of 
audio and produces an MXF wrapped audio track consisting of 2, 4, 8, or 16 
channels of audio. This is combined into the DCP with the video.

•	 Audio files must be uncompressed PCM (WAV) files sampled at 48 KHz and 
16, 20, or 24 bits.

The JPEG 2000 Encoder offers two options for handling audio input content:

zz Single Audio File — The single audio WAV file can be composed of a stereo pair 
of audio channels or an even number of audio channels (up to 16 channels of audio 
content).

NOTE:	 The lite version of the JPEG 2000 Encoder application supports one file 
consisting of a stereo pair or two channels of audio.

zz Multiple Mono Files — The JPEG 2000 Encoder processes up to 16 separate WAV files 
from up to 16 separate data storage locations. This allows you to dedicate specific audio 
files to corresponding audio channels according to multi-channel audio requirements for 
theaters (DCI).

To select a single audio file:

1.	 From the Tasks menu, select Encode.

2.	 Select the Encode Settings tab.

3.	 Below the Audio Files field of the Inputs section, select Single Audio file.

4.	 Beside the Audio Files field, click the  button and navigate to the folder 
containing the audio (WAV) content to be encoded.

5.	 Select a file from the folder and click Open. The path for the selected file appears in the 
Audio File field.
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To select multiple mono files:

1.	 Below the Audio Files field of the Inputs section, select Multiple mono files.

2.	 Beside the Audio Files field, click the  button to open the Audio Channels 
screen.

Figure 6.	 Audio Channels Screen

3.	 For each audio channel, click the respective  button to locate the desired audio 
content and assign the files to the respective “surround sound” channels. 

4.	 Click OK to accept the settings or click Cancel to exit the Audio Channels screen. This 
returns you to the Encode Settings tab (figure 7).

TIP:	 The Microsoft mappings for audio channels 9 through 16 are:

•	 9 — Back Center (BC)

•	 10 — Side Left (SL)

•	 11 — Side Right (SR)

•	 12 — Top Center (TC)

•	 13 — Top Front Left (TFL)

•	 14 — Top Front Center (TFC)

•	 15 — Top Front Right (TFR)

•	 16 — Top Back Left (TBL)

The following mappings are not defined in the DCI specification and may be 
adjusted to suit the application:

•	 17 — Top Back Center (TBC)

•	 18 — Top Back Right (TBR)
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Encoding parameters

Use the Encoding Parameters section of the Encode Settings tab to define the properties 
of the DCP.

The available settings include:

zz Resolution — Choose an output resolution. The drop-down list displays formats that 
correspond with the JMP 9600 hardware profile selected from the Options menu.

zz Chroma — Choose the chroma setting.

TIP:	 When 4:4:4 color sampling is selected, the resulting clip requires the JMP 9600 
to be configured for single channel mode.

zz Frame Rate — Choose a frame rate. The drop-down list displays formats that 
correspond with the JMP 9600 hardware profile selected from the Options menu.

zz Bit Depth — Choose a bit depth (bits per channel).

TIP:	 12 bits per channel is recommended.

zz Colorspace — Choose a colorspace.

TIP:	 Select None when encoding for applications (such as Digital Cinema) using 
XYZ colorspace. The values are passed through without conversion. Otherwise, 
select ICT to create sRGB, RGB, or YCrCb colorspace files.

zz CBL (Code Block) Size — The default (32, 128) is not adjustable unless:

zz Resolution is set to 720p and chroma is set to 4:4:4

zz Resolution is set to 1080p and chroma is set to 4:4:4

zz Resolution is set to 2K and chroma is set to 4:4:4

If any of these settings are selected, you can choose between 32, 188 and 32, 32.

zz Target Mbps — Set the target bit rate.

TIP:	 The default (suggested) values are 125 Mbps for 4:2:2 files and 250 Mbps for 
4:4:4 files.

To adjust the settings:

1.	 Click the  button for an available setting. This displays the drop-down list of options.

NOTE:	 Available settings depend on the JMP 9600 hardware profile that is set in 
the Options menu (see “JMP 9600 Hardware Profile”).

2.	 From the drop-down list, select the desired option. 
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Outputs

Use the Outputs section of the Encode Settings tab to define the identity of the DCP and 
the location where the DCP is stored after it is generated.

To adjust the output settings:

1.	 From the Tasks menu, select Encode.

2.	 Select the Encode Settings tab.

3.	 In the Composition Name field of the Outputs section, enter a unique name for the 
DCP.

4.	 Beside the Output Folder field, click the  button to navigate to the folder 
designated as the storage location for the final Digital Cinema Package output. The path 
for the selected folder appears in the Output Folder field. 

NOTE:	 In an encoding array, the source files (frames and audio) must be on a drive 
mapped with the same drive letter on both the local and remote machines. 
This applies to the output folder as well. For example, if an output folder on 
the local machine is mapped to F:, the output folder on the remote machine 
must also be mapped to F: (see “Encoding Across Multiple Computers 
[Remote Machines]”). When encoding with a single machine, use local 
drives for the source and output folders for better performance.

5.	 Click OK to save your settings and exit the Encode Settings screen or click Cancel to exit 
the screen without saving any changes.

Each unique composition name generates a new DCP for the output folder. These appear in 
the Composition column of the JPEG 2000 Encoder main screen.
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Effect Settings tab

The features on the Effect Settings tab allow you to crop and scale the video for  
multi-screen applications or to match the native resolution of the target display device.

NOTES:	 •	 The available effect options depend on the settings in the encoding parameters 
and the incoming frame size (see “Encode Settings tab”).

•	 The Effect Settings tab is disabled if the resolution of the source graphics 
file matches the target encoder resolution.

Figure 7.	 Effect Settings Tab

Disabled

The Disabled option on the Effect Settings tab indicates that no effects are in use and 
the output display window remains black.

The image description that is displayed for this option includes:

zz Image Size — The horizontal and vertical pixel format of the source frame

zz Target Size — The desired pixel aspect of the output frame

zz Position — 0,0 (default position). No adjustment is possible in this mode.
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Crop mode

To enable crop mode:

On the Effect Settings tab, click Crop Mode.

If the input frame is larger than the target frame, an image appears in the output 
window with a light blue rectangle superimposed upon it. 

NOTE:	 If the input frame is smaller than the target frame, Crop mode is not 
available. 

The blue rectangle represents the area that will be kept after the cropping is complete. 
Cropping the image removes all pixels outside of the blue rectangle. The crop area can be 
modified as needed.

The image description that is displayed for this option includes:

zz Image Size — The horizontal and vertical pixel format of the source frame

zz Target Size — The desired pixel aspect of the output frame

zz Position — The crop window location on the frame. The default position is the top left 
of the output frame (pixels 0,0).

The size of the crop region can be any size from 32x16 pixels up to and including the target 
resolution.

To reposition the image:

On the Effect Settings tab, click and drag the image on the screen.

- or - 

Click the Up, Down, Left, and Right buttons to nudge the image in single-pixel 
increments.

- or -

1.	 Click the  button beside the Position field to open the Change Value screen.

Figure 8. Change Value Screen

2.	 Enter specific pixel coordinates in the New Position X and New Position Y 
fields.

3.	 Select the Save values check box if desired.

4.	 Click OK to exit the Change Value screen.

The position information updates in real time.
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The crop size appears below the position information. The default crop size is the output 
resolution set on the Encode Settings tab. Cropping works only if the input image is 
larger than the output frame.

To adjust the crop size:

On the Effect Settings tab, click and drag the corners of the crop region box within 
the Crop Editor window to change the crop size.

- or - 

1.	 Click the  button beside the Crop Size field to open the Change Value screen.

Figure 9. Change Value Screen 

2.	 Enter a new pixel width and height in the respective New Width and New Height 
fields.

3.	 Select the Save values check box if desired. If the Save values check box is 
selected, copies of the cropped output frames are saved along with the DCP.

4.	 Click OK to exit the Change Value screen.

In the Crop Regions section of the Effect Settings tab, click the  button to add as 
many crop regions as needed. Each crop region is encoded as a separate DCP.

For example, you can use multiple overlapping crop regions to set up frame segments that 
will be sent to separate projectors and blended on screen to form a single large image.

NOTE:	 If the crop size is less than the encoder target size, the cropped image is 
centered in the output video. 
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To rename a crop region for easier identification:

1.	 On the Effect Settings tab, double-click a name in the Crop Regions section. The 
Crop Region Name screen opens.

Figure 10.	 Crop Region Name Screen

2.	 In the New Name field, enter a name to identify the crop region.

3.	 Click OK to exit this screen and return to the Effect Settings tab.

Stretch mode

To enable stretch mode, click Stretch Mode on the Effect Settings tab. When stretch 
mode is enabled, the display shows the input frame stretched to fit into the output frame 
determined by the encoder settings on the Encode Settings tab. Stretch mode can be 
applied when the input frame is smaller or larger than the output frame so that the input 
size is forced to the output size.

The image description that is displayed for this option includes:

zz Image Size — The horizontal and vertical pixel format of the source frame

zz Target Size — The desired pixel aspect of the output frame

zz Position — 0,0 (default position). No adjustment is possible in this mode.

Letterbox mode

To enable letterbox mode, click Letterbox Mode on the Effect Settings tab. The video 
frame that is displayed is centered horizontally and vertically with a red border in letterbox 
format.

NOTES:	 •	 Letterbox mode functions only if the input frame is smaller than the output 
frame determined by the encoder settings on the Encode Settings tab.

•	 Depending on the resolution of the source files and the target resolution, 
this mode may also result in pillarbox images (black bars on the sides) or 
windowbox images (black border around the image).

The image description that is displayed for this option includes:

zz Image Size — The horizontal and vertical pixel format of the source frame

zz Target Size — The desired pixel aspect of the output frame as defined on the Encode 
Settings tab

zz Position — It is dependent upon the sizes of the input and output frames. By default, 
the source image is centered within the output image size.
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To reposition the image:

On the Effect Settings tab, click and drag the image on the screen.

 - or - 

Click the Up, Down, Left, and Right buttons to nudge the image in single-pixel 
increments.

- or -

1.	 Click the  button beside the Position field to open the Change Value screen.

2.	 Enter specific pixel coordinates in the New Position X and New Position Y 
fields.

3.	 Select the Save values check box if desired.

4.	 Click OK to exit the Change Value screen.

The position information updates in real time.

Drawing Settings tab

Using the features mentioned on the Drawing Settings tab, you can overlay text blocks 
and timecode stamps on the video output frames.    

Figure 11.	Drawing Settings Tab
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Text editing

To add a text block:

1.	 On the Drawing Settings tab, click the Enabled radio button. This activates the 
settings on the tab.

2.	 In the Text section, click the  button and select Text from the drop-down list of 
options.

3.	 In the Text section, click the  button to add a text block.

4.	 Edit the text block that appears in the upper left corner of the output display.

NOTE:	 Move the text block into the output frame (within the red-bordered image) 
or it will not appear on the output screen. The text block position can be 
anywhere on the output frame.

To reposition the text block:

On the Drawing Settings tab, click and drag the text block on the screen.

- or - 

Click the Up, Down, Left, and Right buttons to nudge the text block in single-pixel 
increments.

- or -

1.	 Click the  button beside the Position field to access the Change Value screen.

2.	 Enter specific pixel coordinates in the New Position X and New Position Y 
fields.

3.	 Select the Save values check box to save these settings as preset values for use in 
the future.

4.	 Click OK to exit the Change Value screen.

The position information updates in real time.

To modify the text in a text block:

1.	 In the Output section of the Drawing Settings tab, right-click the text and select 
Change Text from the drop-down menu. The TextDialog screen opens.

 

Figure 12.	 TextDialog Screen

2.	 In the Text field of the TextDialog screen, enter the desired text.
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3.	 Click Change beside the Name field of the Font Information section to change the font 
style. The Font screen opens.

Figure 13.	 Font Screen

NOTE:	 Depending on the overlay font in use, the “tails” of lowercase characters 
and other “flourishes” in decorative fonts may be cut off in the Preview 
section of the Font screen. The actual font output displays correctly.

4.	 On the Font screen, select the desired font family, font style, and font size.

5.	 Click OK to return to the TextDialog screen.

6.	 Modify the text color.

a.	 In the Font information section of the TextDialog screen, double-click the Font 
Color box to change the font color. The Select a Color screen opens.

Figure 14. Select a Color Screen

b.	 Adjust the color settings as desired.

c.	 Click OK to accept the text color parameters and return to the TextDialog screen. 
Alternatively, click Cancel to return to the TextDialog screen without making 
changes.
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7.	 Modify the border color:

a.	 In the Font information section of the TextDialog screen, double-click the Border 
Color box to change the border (stroke) color. The Select a Color screen opens.

b.	 Adjust the color settings as desired.

c.	 Click OK to accept the border color parameters and return to the TextDialog screen. 
Alternatively, click Cancel to return to the TextDialog screen without making 
changes.

8.	 On the TextDialog Screen, click OK to return to the Drawing Settings tab.

Timecode stamp

To add a timecode stamp:

1.	 In the Text section of the Drawing Settings tab (figure 11), click the  button and 
select Timecode from the drop-down list of options.

2.	 In the Text section, click the  button to add a timecode stamp. A timecode stamp 
(00:00:00:00) appears in the upper left corner of the output display. 

NOTE:	 Move the timecode stamp into the output frame (within the red-bordered 
image) or it will not appear on the output screen. The text block position 
can be anywhere on the output frame.

3.	 You can edit the position and appearance of the timecode stamp using the same 
procedures as described for text blocks in “Text editing.”

You cannot edit the contents of the timecode stamp. This changes automatically for 
each frame during the encoding process.

4.	 On the Drawing Settings tab, click OK to return to the main screen of the  
JPEG 2000 Encoder. 

Options Menu

The options available on the Options menu depend on which version of the application (lite 
or full version) is in use.

Threads

NOTE:	 The Threads option is available only with the full version of the software.

This option allows the use of multiple threads (computer processor cores) for increased 
system throughput.

To adjust the threads setting:

1.	 From the Options menu, select Threads to access the slider bar.

2.	 Click and drag the slider bar to change the threads value. The maximum number is 
limited to the number of cores on the computer.
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JMP 9600 Hardware Profile

The options listed on the JMP 9600 Hardware Profile submenu of the Options menu 
tailor the output of the encoder for particular use on the JMP 9600 player. Select a profile to 
define which encoding parameters are best suited to the required DCP. See the  
JMP 9600 User Guide for more information about the JMP 9600.

To select the JMP 9600 hardware profile:

From the Options menu, locate the JMP 9600 Hardware Profile submenu and 
select one of the listed options: 

zz V. 2.0 HD (Default)

zz V. 2.0 2K

zz V. 3.0 2K

A check mark appears beside the selected option.

NOTE:	 V. 3.0 2K supports high frame rates of 1920x1080 or 2K with frame rates of 48, 
50, 59.94, or 60.

Validate Frames (Full Version Only)

This option validates the video data to be encoded for continuity and other frame 
information. Validation detects errors before the encoding process begins. By using the 
Validate Frames option you can validate a composition apart from encoding.

To start manual validation:

1.	 From the Options menu, select Validate Frames. The following screen opens:

Figure 15.	 Validate Screen

2.	 In the Video Path field, click the  button to choose a folder containing video data.

3.	 Select Quick Validation or Complete Validation.

Quick Validation  selects a small number of random frames to verify if their size is 
the same whereas Complete Validation checks the sizes of all the frames. Complete 
Validation can be used in instances such as when there is an issue with the encoded 
content and you want to detect if there is a frame that is causing the issue.

4.	 Click Validate to begin the validation process or click Cancel to exit.

You can also choose whether frame validation occurs before encoding:

1.	 From the Options menu, select More Options.

2.	 Select the Validate frames before encoding check box.

3.	 Select either Quick Validation or Complete Validation as the validation type.

4.	 Click OK to return to the JPEG 2000 Encoder main screen.
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More Options

More Options on the Options menu controls certain basic parameters of the JPEG 2000 
Encoder.

To adjust the settings listed under this option:

1.	 From the Options menu, select More Options. The JPEG 2000 Encoder Options screen 
opens:

Figure 16.	 JPEG 2000 Encoder Options Screen

2.	 Select or clear the settings as needed. Available options include:

zz Start application minimized. — When starting the JPEG 2000 Encoder, 
the application opens in a minimized view in the notification area of the desktop 
taskbar.

zz Validate frames before encoding. — Select this check box, then select Quick 
Validation or Complete Validation based on the desired validation type. When 
Validate frames before encoding is selected, frames are validated at the start 
of encoding a composition (see “Validate Frames”).

zz Play sound when encoding is completed. — You can change the default 

sound by clicking the  button to browse to a different sound file.

zz Move .j2c files to “EncodedFrames” in the output folder. — This 
option saves copies of the video frames in a separate location from the DCP.

zz Enable/Disable logs. — This is a text file that offers a “properties view” of the 

encoded package. Click the  button to change the location of this file.

3.	 Click OK to accept the modified settings or click Cancel to keep the existing settings 
and return to the main screen.

Help Menu

Licensing and Activation
To activate the full version of the JPEG 200 Encoder and view other license information, 
select Licensing and Activation from the Help menu (see “Licensing and 
Activating the Full Version”).

End User License Agreement
To view the End User License Agreement, select End User License Agreement from 
the Help menu.
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About
To view information about the software, including the version that is in use, select 
About from the Help menu. 

Single Clip Encoding
Before you start to encode a single DCP or clip, ensure that the relevant settings of the  
JPEG 2000 Encoder are correct.

Figure 17.	JPEG 2000 Encoder Main Screen
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To encode a single DCP or clip:

1.	 Right-click an encoding task listed in the Composition column of the JPEG 2000 Encoder 
main screen and select Start from the drop-down menu. The available options on the  
drop-down menu include:

zz Start — Starts the encoding process for this item only

zz Stop — Pauses the encoding process for this item only. If there is a single DCP listed 
in the Composition column, you can also click Stop All.

zz Edit — Opens the Encode Settings tab (see “Encode Settings tab”).

zz Open Output in Explorer — Displays the contents of the DCP in a Windows 
Explorer panel

zz Remove this job — Deletes this item from the Composition column

zz Remove All Completed — Deletes all completed encoding items

2.	 Observe the progress bar and ensure that encoding is active.

If there is a single encoding task listed in the Composition column, you can also click Start 
All to start encoding the file.

To stop or pause the encoding process:

Right-click a file listed in the Composition column and select Stop from the drop-down list. 
You can also click Stop All on the main screen.

Batch Encoding
Before you start to encode a batch of clips, ensure that the relevant settings of the  
JPEG 2000 Encoder are correct. 

If more than one Composition name appears in the Composition list, the Batch Encode 
feature is available.

To encode a batch of files:

1.	 On the main screen of the JPEG 2000 Encoder, click Start All.

2.	 Observe the progress bar and ensure that encoding is active.

To stop or pause the batch encode process:

On the main screen of the JPEG 2000 Encoder, click Stop All.

Status Indication
The progress bar that appears beside the Composition name displays a real-time measure of 
the encoding process while it is underway. The status of the encoding process is displayed 
along the bottom of the application window:

zz Ready — The system is ready to encode. This changes when encoding begins.

zz Encoding — The system is encoding data (the progress bar moves slowly to the right). 
When encoding is complete, the status reverts to “Ready.”

zz Time Left — The amount of time remaining until the current data set is encoded

zz Elapsed Time — The length of time that has passed since starting to encode the 
current data set. When encoding is complete, the status reverts to “Ready.” The DCP is 
now available for transfer to a JMP 9600 JPEG 2000 Media Player.
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Encoding Across Multiple Computers (Remote Machines)
You can incorporate a number of computers on a network into an encoding array to greatly 
expand the throughput of the encoding system. The time required to encode the quantity of 
data is reduced. This is significant as JPEG 2000 files can be very large (terabytes).

NOTE:	 The same (fully licensed) version of the JPEG 2000 Encoder software must be 
installed on each computer that makes up the array.

When used in an array, the software behaves as a dual-master system. During the encoding 
process, specific computers within the array can be set to encode a different DCP while 
the remaining computers continue (albeit with fewer processing cores available) encoding 
the specified DCP. Each computer running the JPEG 2000 Encoder is visible by the other 
computers in the system, thus status and availability is known by each computer. This allows 
you to bring more or fewer computers online for an encoding task.

NOTES:	 •	 The source files (frames and audio) must be on a drive mapped with the same 
drive letter on both the local and remote machines. This applies to the output 
folder as well. For example, if an output folder on the local machine is mapped 
to F:, the output folder on the remote machine must also be mapped to F:.

•	 Actual encoding throughput in an array depends on the network speed more 
than the processing speed of the individual computers that make up the array. 
Consequently, adding computers may not necessarily increase throughput. 
Verify the capacity of your network with your administrator before adding 
machines.

•	 The encoder service is enabled through port 9600 for distributed encoding. 
To connect to the JPEG 2000 Encoder on a remote machine with an enabled 
firewall, it is necessary to add an exception for this port in the local firewall.

•	 For Windows 7 users: to enable port 9600, it is necessary to add a rule for TCP 
port 9600 in inbound rules as well as outbound rules.

To set a multiple-encoding array:

1.	 In the Remote Machines section of the JPEG 2000 Encoder main screen, click Add. The 
New Remote Machine screen opens.

Figure 18.	 New Remote Machine Screen

2.	 On the New Remote Machine screen, enter the IP address or computer name for a 
machine on the network.
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3.	 Click OK to return to the main screen or click Cancel to return to the main screen 
without adding a machine. The computer IP address or name appears in the Remote 
Machines section of the main screen. The following states can appear beside each listed 
remote machine:

zz Ready — Indicates that the computer is available for encoding tasks

zz Unavailable — Indicates that the computer is not connected. Check with your 
network administrator to ensure that necessary connections are in place and that 
the JPEG 2000 Encoder software (same version) is loaded on the remote device. 

4.	 Repeat steps 1 through 3 to add more remote machines as needed. The system is now 
set up for processing data over multiple machines.

To remove a computer from a multiple-encoding array:

1.	 In the Remote Machines section of the main screen, select one of the listed computers 
by clicking on it.

2.	 Press the <Delete> key on your keyboard. 
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Reference

This section provides reference information regarding the encoding and packaging processes 
when creating content for the JMP 9600 JPEG 2000 Media Player. Topics that are covered 
include:

zz Encoding and Packaging Overview

zz Encoding Related Specifications

zz Part Numbers

Encoding and Packaging Overview
Creating content for the JMP 9600 using the JPEG 2000 Encoder is accomplished in three 
stages: encoding, wrapping, and packaging, as shown in figure 19.
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Figure 19.	Encoding, Wrapping, and Packaging Process

zz Encoding — Each frame of source video is compressed by passing the raw pixel data 
through a JPEG 2000 compressor. The compressor creates a stream of JPEG 2000-coded 
frames. The parameters that are applied in the JPEG 2000 Encoder software affect the 
compression level and quality of the image.

The source audio is encoded using pulse code modulation (PCM).

zz Wrapping — The individual compressed video frames are combined into a single track 
file using the Material Exchange Format (MXF). The audio is converted into a separate 
MXF track file.

zz Packaging — Additional control files describing the format of, and the relationship 
between, the audio and video files are generated. The resulting files are collectively 
known as a Digital Cinema Packagte (DCP) as described in the DCI specification.

Video Track Files

A video track file is the smallest unit of video in the system. It is an MXF container that has 
all of the compressed video data and associated meta-information necessary to recreate a 
piece of video (for example, see the v.mxf file shown in figure 19).

The JMP 9600 supports unencrypted frame-wrapped video track files that conform to  
SMPTE 377M-2004 and SMPTE 422M-2006 standards.
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Audio Track Files

An audio track file is the smallest unit of audio in the system. It is an MXF container that has 
all of the PCM-encoded, compressed audio data and associated meta-information necessary 
to recreate a piece of audio (for example, see the a.mxf file shown in figure 19). The  
JMP 9600 supports frame-wrapped audio track files that conform to SMPTE 377M-2004 and 
SMPTE 382M-2007 standards.

Reels

In the movie industry, it is common practice to split a feature onto several film reels for 
distribution. This concept is supported digitally by splitting a feature into several separate 
files. The digital reel is a track file (see “Video Track Files” and “Audio Track Files”) that 
contains either video content or audio content. You may want to use multiple reels to create 
more manageable file sizes such as hundreds of gigabytes rather than a few terabytes).

Composition Playlist

A composition playlist (CPL) is a text file that contains all of the information necessary to 
reassemble a presentation from its individually encoded components and to specify how the 
files for a specific presentation should be played back. The CPL file points to the reels (see 
figure 20), identifying locations (folders) and filenames, and specifies the manner in which 
the audio and subtitles are synchronized with the picture. The CPL can specify one video reel 
and one audio reel or multiple reels of both types, depending on the wrapping process. 

...

aud1.mxfvid1.mxf

aud2.mxfvid2.mxf

Composite
Playlist

audn.mxfvidn.mxf

Figure 20.	Composite Playlist

Packing list and asset map

The packing list and asset map provide size and checksum information for audio and video 
MXF files in the DCP so that the player can ensure no corruption occurred during the file 
transfer. These files are described in SMPTE 429-8-2006 and SMPTE 429-9-2007 standards.

Encoding Related Specifications
zz SMPTE 377M-2004 — Material Exchange Format (MXF) FIle Format

zz SMPTE 422M-2006 — Mapping JPEG 2000 Codestreams into the MXF Generic 
Container

zz SMPTE 382M-2007 — Mapping AES3 and Broadcast Wave Audio into the MXF Generic 
Container

zz SMPTE 429-3-2006 — D-Cinema Packaging - Sound and Picture Track FIle

zz SMPTE 429-4-2006 — D-Cinema Packaging - MXF JPEG 2000 Application

zz SMPTE 429-7-2006 — D-Cinema Packaging - Composition Playlist

zz SMPTE 429-8-2006 — D-Cinema Packaging - Packet List

zz SMPTE 429-9-2007 — D-Cinema Packaging - Asset Mapping
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Part Numbers
These items are the available software versions and JMP 9600 models. The JPEG 2000 
Encoder software included with the JMP 9600 supports content preparation for one unit;  
two-channels of audio per video clip and single processor encoding only.

Available Models Description Part Number

J2KENC JPEG 2000 Encoding Software 79-550-01

J2KENC-PRO JPEG 2000 Professional Encoding Software 79-550-02

JMP 9600 HD JPEG 2000 Media Player HD 60-1135-01

JMP 9600 HD 128 JPEG 2000 Media Player HD 128 GB SS 60-1135-02

JMP 9600 2K JPEG 2000 Media Player 2K 60-1136-01

JMP 9600 2K 128 JPEG 2000 Media Player 2K 128 GB SS 60-1136-02
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