Streaming To Wowza® Media Server® 3
SME 100 H.264 Streaming Media Encoder
Conventions Used in this Guide

In this user guide, the following is used:

NOTE: A note draws attention to important information.

Commands are written in the fonts shown here:

```
^AR Merge Scene,,Op1 scene 1,1 ^B 51 ^W^C
[01] R00040030004000080000600 [02] 35 [17] [03]
Esc[x1]"x17""x20""x23""x21"CE←
```

NOTE: For commands and examples of computer or device responses mentioned in this guide, the character “0” is used for the number zero and “O” represents the capital letter “o”.

Computer responses and directory paths that do not have variables are written in the font shown here:

```
Reply from 208.132.180.48: bytes=32 times=2ms TTL=32
C:\Program Files\Extron
```

Variables are written in slanted form as shown here:

```
ping xxx.xxx.xxx.xxx –t
SOH R Data STX Command ETB ETX
```

Selectable items, such as menu names, menu options, buttons, tabs, and field names are written in the font shown here:

```
From the File menu, select New.
Click the OK button.
```

Third Party Equipment and Software

These procedures are based on documentation created by a third party. Hardware and software support for the Wowza Media Server is provided by Wowza Media Systems at www.wowza.com.
# Contents

## Introduction
- Overview ........................................ 1
- Requirements .................................... 1
- SME 100 Connection ............................ 2

## Setup and Configuration
- Computer (Server) Setup ...................... 3
- Accessing the SME 100 Web-based User Interface ... 3
- SME 100 Configuration .......................... 4
- Wowza Set Up and Configuration .......... 6
  - Pull Streaming Method .................. 6
  - Push Streaming Method ................ 6
- Automatic Media Server Startup (Optional) .... 7
  - Automatic Streaming (Optional) ....... 8
  - Additional Configuration ............. 9
- Wowza Server Startup ......................... 10
- Setting Up a Viewer Web Page ............. 10
  - Downloading Media Server Files ....... 10
  - Verify the Media Server Files .......... 11
  - Setting Up Flash® Player ................ 12
  - Setting Up an HTML5 Player ............ 13
  - Setting Up Silverlight® Player ........ 14
  - Setting Up Stream Autodetection (Flash and HTML5 Players Only) ........... 15
  - Setting Up the Index Page (Main Page) .... 16
  - Configuring Wowza Stream Manager ...... 17
  - Accessing the Viewer Web Page .......... 18

## Reference Information
- Setting Up Stream Hyperlinks ............. 19
- List of Ports Used for Streaming .......... 21
- Opening Additional Stream Ports .......... 22
Introduction

This section provides information about:

- **Overview**
- **Requirements**

**Overview**

This guide contains information for setting up Wowza Media Server version 3 with an audio/video stream from the SME 100.

**NOTES:**

- For information on setting up a SME 100 network, see the **SME 100 User Guide** available at [www.extron.com](http://www.extron.com).
- The procedures presented in the following sections use a Microsoft® Windows® operating system to set up Wowza Media Server.
- These procedures use default directory locations of all installed software programs (specifically Internet Information Services [IIS] and Wowza Media Server). Directory locations for installed programs can be changed if necessary:
  
  % [IIS install directory] = C:\inetpub\wwwroot

  % [Wowza version 3.0 install directory] = C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0

- Alternatively, Darwin Streaming Server ([dss.macosforge.org](http://dss.macosforge.org)) can be used to create a media server.

**DISCLAIMER:**

These procedures are based on documentation created by a third party. Hardware and software support for the Wowza Media Server is provided by Wowza Media Systems at [www.wowza.com](http://www.wowza.com).

**Requirements**

This section lists the requirements that are needed to create a Wowza Media Server.

- Computer or server running Microsoft® Windows® XP operating system or higher. A 64-bit version of Windows is recommended.
- Static IP address for the computer or server (highly recommended)
- Wowza Media Server 3 (available at [www.wowza.com](http://www.wowza.com))
- Wowza Media Server License (available at [www.wowza.com](http://www.wowza.com))
- Java™ SE JDK 6 or higher (available at [www.oracle.com](http://www.oracle.com))

**NOTE:** Be certain that the Java development kit (JDK) is downloaded. Do not download the consumer version of Java.
SME 100 Connection

The SME 100 can be integrated with Wowza Media Server 3 and stream to displays using an existing LAN system (100 Mb or faster). A direct connection to displays or the control PC is not necessary. The control device can be connected using the same LAN system.

**NOTE:** Overall streaming performance is based on the third-party hardware and software system.

---

**Figure 1. Typical Wowza Media Server Application**
Setup and Configuration

This section provides information about:

- Computer (Server) Setup
- Accessing the SME 100 Web-based User Interface
- SME 100 Configuration
- Wowza Set Up and Configuration
- Wowza Server Startup
- Setting Up a Viewer Web Page
- Accessing the Viewer Web Page

Computer (Server) Setup

The following procedure converts a computer or server into a media server powered by Wowza Media Server. On the computer / server running Microsoft Windows:

1. Set a static IP address.
2. Install / enable Internet Information Services (IIS).

NOTE: To install, enable, and manage Internet Information Services (IIS) using Microsoft® Windows®, select Start 🕒 > Help and Support or see the "Windows Help and How-to" documentation available online.

3. Install Java™ SE JDK 6 or higher (available at www.oracle.com).
4. Obtain and apply a license to Wowza Media Server (available at www.wowza.com).
5. Install Wowza Media Server 3 or higher (available at www.wowza.com).
6. Install or update Adobe® Flash® Player to the latest version (available at www.adobe.com).

Accessing the SME 100 Web-based User Interface

To access the web-based user interface, open a web browser on the Wowza server and enter the IP address of the SME 100 (default IP address is 192.168.254.254) into the address bar.

For detailed information on how to access and use the web-based user interface, see the SME 100 User Guide available at www.extron.com.
SME 100 Configuration

Use the following procedure to configure the SME 100 using the Pull Streaming method.

NOTE: For detailed information on accessing and configuring the SME 100 web-based user interface, see the SME 100 User Guide available at www.extron.com.

1. Access the web-based user interface and click on the Configuration tab. The Configuration page appears.
2. From the Configuration page, click the Encoder Settings link located on the left sidebar. The Encoder Settings page appears.
3. The SME 100 can be set up to connect to the Wowza Media Server using either a Pull or Push stream depending on your application. The Encoder must be configured for the proper setup.

![Encoder Configuration Table]

**Figure 2. Encoder Configuration**

In the encoder configuration section (see figure 2) it is important to consider several items:

- Resolution
- Frame Rate
- Stream Mode
- Stream Type
- Profile Type
- Profile Level
- Video Bit Rate
- Audio Bit Rate
- GOP Length
- Audio Delay
- Kbps

NOTE: Always consult the Wowza Forum for the latest compatibility details.

Depending upon the target audience, the settings will require adjustments. For example, the profile level has a range from three to five with several intervals. Raising the profile level too high may not allow mobile devices to play the stream.

Configure the audio bit rate setting as desired. A value between 64 kbps to 128 kbps is recommended for the audio output bit rate, but may vary depending on the application.

4. To set up the SME 100 for pull streaming use the RTSP Configuration panel.

![RTSP Configuration Table]

**Figure 3. RTSP Configuration Panel Settings**
5. To set up the SME 100 for push streaming, use the streaming configuration panel.

<table>
<thead>
<tr>
<th>Stream Control</th>
<th>Stream Method</th>
<th>Destination IP</th>
<th>Destination Port</th>
<th>MTU</th>
<th>TTL</th>
<th>QoS (Differentiated Services)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable</td>
<td>Multi TS/UDP</td>
<td>239.199.188.138</td>
<td></td>
<td></td>
<td></td>
<td>Best Effort</td>
</tr>
<tr>
<td>SAP Control</td>
<td>Session Name</td>
<td>Session Description</td>
<td>Keywords</td>
<td>Author</td>
<td>Announce Frequency</td>
<td>10000</td>
</tr>
<tr>
<td>Disable</td>
<td>SME-100-HD-08-4</td>
<td>SME Live Stream</td>
<td>Live Streaming</td>
<td>Extron</td>
<td>0 sec</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 4. Streaming Configuration Panel Settings**

Wowza can ingest any of the following streaming methods from the SME 100:

- Uni TS/UDP
- Uni TS/RTP
- Multi TS/UDP
- Multi TS/RTP

When using a unicast method the destination IP will be the Wowza Server IP (Example: 192.168.1.100). Wowza recommends 10000 for the destination port.

Using a multicast method, the destination IP will be the multicast address (Example: 239.199.188.138). Wowza recommends 10000 for the destination port.

SAP information can be enabled or disabled depending on the application requirements.

6. When configuration is complete, turn on the stream by changing the **Stream Control** to **Enable**.

**NOTE:** Consult the SME 100 User Guide to verify push streaming.
Wowza Set Up and Configuration

Once the SME 100 devices are configured for the Wowza Media Server, use the following procedure to connect them for streaming media content.

NOTES:
- The file name is case sensitive and stream is the extension. Type the filename exactly as shown.
- Regardless of the streaming method, each SME connected to the server requires its own stream file. Suggested file naming is SME1.stream, SME2.stream, SME3.stream and so on.

Pull Streaming Method
1. On the computer with Wowza Media Server installed, open Notepad and type:
   rtsp://[SME 100 IP address]/extron.
2. From the File menu, select Save As.
3. From the Save as type drop-down menu, select the All Files option.
4. In the File name field, enter SME1.stream.
5. Save the file to the following location:
   [Wowza install directory]\content

Push Streaming Method

Using Unicast
1. Open Notepad (on the computer with Wowza Media Server installed) and type:
   udp://0.0.0.0:10000.
   The above address is used by Wowza with this streaming method.
2. Save the text file as SME1.stream
3. Save the file to the following location:
   [Wowza install directory]\content

Using MultiCast
1. Open Notepad (on the computer with Wowza Media Server installed) and type:
   udp://239.199.188.138:10000, where <239.199.188.138> is the multicast IP address used in the SME 100 streaming configuration.
2. From the File menu, select Save As.
3. From the Save as type drop-down menu, select the All Files option.
4. Save the text file as SME1.stream
5. Save the file to the following location:
   [Wowza install directory]\content
**Automatic Media Server Startup (Optional)**

Use the following procedure to have the Wowza Media Server automatically start up when the computer / server is powered on.

1. From the desktop (on the computer / server with Wowza Media Server installed), select Start > Control Panel > Administrative Tools > Services.

2. The Services window appears. Double-click on **Wowza Media Server** (see figure 5).

3. The Wowza Media Services Properties window appears. From the **Startup type** drop-down menu, select **Automatic** and click **OK** (see figure 6). Wowza Media Server is now set up to automatically start when the computer / server is powered on.

---

**Figure 5. Services Window**

The Wowza Media Services Properties window appears. From the **Startup type** drop-down menu, select **Automatic** and click **OK** (see figure 6). Wowza Media Server is now set up to automatically start when the computer / server is powered on.

**Figure 6. Wowza Media Services Properties Window**
Automatic Streaming (Optional)

Use the following procedure to automatically start streaming when the computer / server running Wowza Media Server is powered on.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed).
   - [Wowza install directory]\conf

2. Right-click on the StartupStreams.xml file and select Edit to open Notepad.

3. Find the following code in the document (the code should be at the top of the document).
   <Root>
   <startupstreams>

4. Below the <startupstreams> line, add the following code.
   <StartupStream>
     <Application>live/_definst_</Application>
     <MediaCasterType>rtp</MediaCasterType>
     <StreamName>SME1.stream</StreamName>
   </StartupStream>

   **NOTE:** To automatically start more than one stream:
   
   1. Copy and paste the code shown in this step as many times as necessary into the StartupStreams.xml file.
   2. Change the SME1.stream (case sensitive) code to the name of the stream file that requires an automatic start.
   3. Create additional stream files using steps 1 through 4 of the "Wowza Set Up and Configuration" section on page 3.

4. From the File menu, select Save to save the StartupStreams.xml file. Specified streams are now automatically started when the computer / server running Wowza Media Server is powered on.
**Additional Configuration**

By default, Wowza Media Server enables interleaved mode in its software. If interleaved mode is left enabled, the media server may read all data packets as RTSP packets. When the media server responds with errors that are reported to log files or the terminal window, **interleaved mode should be disabled.**

Use the following procedure to disable interleaved mode. Make sure the media server has been stopped or shut down before beginning this procedure.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed).
   - [Wowza install directory]\conf\live

2. Right-click on the Application.xml file and select **Edit** to open Notepad.

3. Find the following code in the document.

   ![Figure 7. Interleave Code](image)

4. Change the text within the `RTPTransportMode` tags (red outlined text above) from `interleave` to `udp` (see example code below).

   ```xml
   <RTPTransportMode>udp</RTPTransportMode>
   ```

5. From the **File** menu, select **Save** to save the Application.xml file and restart the Wowza Media Server.
**Wowza Server Startup**

Now that Wowza Media Server has been properly configured and is able to stream from the SME 100, the actual service needs to be started. Use the following procedure to start the media server.

**NOTES:**

It is recommended to configure the computer / server to start the Wowza Media Server program and begin streaming automatically when powered on. See the "Automatic Media Server Startup" section on page 7 and the "Automatic Streaming" section on page 8 for configuration information.

Using an automatic startup configuration is important because if the computer / server ever crashes and needs to be rebooted, the Wowza Media Server program will automatically startup and begin streaming when the computer / server has finished rebooting.

1. From the desktop (on the computer / server with Wowza Media Server installed), select **Start > All Programs > Wowza Media Server 3.0 > Wowza Startup**.

   **NOTE:** Wowza Media Server version 3.0 or higher can be selected for this procedure.

2. A terminal window appears notifying the user that the media server is running.

   **NOTE:** The terminal window must remain open. Closing the terminal window stops the service that is running on the computer / server.

**Setting Up a Viewer Web Page**

Use the following sections to create a basic web page that can be used by various users.

**NOTE:** Before starting these sections, Internet Information Services (IIS) must be installed on the computer / server running Wowza Media Server. To install and enable IIS using Microsoft® Windows®, select **Start > Help and Support** or see the "Windows Help and How-to" documentation available online.

**Downloading Media Server Files**

This procedure uses a default web page created by Extron. Use the following procedure to download the necessary streaming media server files.

1. On the computer / server with Wowza Media Server installed, go to the SME 100 product web page.

2. From the SME 100 product page, click the Downloads tab.

3. Click the **Wowza Media Server Configuration** link.

4. On the next screen, enter the requested information, then click **Download Wowza_Media_Server_Configuration_vnxnn.zip** (where n is the version number).

5. Follow the instructions from the download screens to save the zip file to the computer. Note the folder where the file is saved.

6. Using the file browser, locate the downloaded zip file and extract it to the following location:
   - C:\inetpub\wwwroot
Verify the Media Server Files

This procedure is used to verify that the downloaded server files are in the correct directory.

1. On the computer / server with Wowza Media Server installed, navigate to the following location:
   • [IIS install directory] (default extraction directory is C:\inetpub\wwwroot)

2. Verify that the zip file downloaded in the previous section ("Downloading Media Server Files") and has been correctly extracted into the directory shown above.

   **NOTE:** Various media player folders and an index.html file should be seen.

3. Use the following sections to edit the files so that they are compatible with the Wowza Media Server network.

   **NOTE:** The procedures on the following pages provide example file configurations that can be used when setting up the viewer web page. Use these file configuration examples for reference and edit each file as desired.
Setting Up Flash® Player

Use the following procedure to edit the Flash player file.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed).
   • [IIS install directory]\flash

2. Right-click on the Flash.html file and select Edit to open Notepad.

3. Edit the following text (see figure 8).

4. From the File menu, select Save to save the Flash.html file.

---

Figure 8. Flash.html Notepad Document

a. In the Server line (outlined in red) replace the ADDIPHERE characters with the IP address of the computer / server with Wowza Media Server installed (see example below).


b. If necessary, change the SME1.stream text (outlined in red; this entry is case sensitive) with the appropriate stream file name created using steps 1 through 4 of the "Wowza Set Up and Configuration" section on page 3.

c. If necessary, change the video player window size by editing the values outlined in green. The first value represents the horizontal size (width) of the player window. The second value represents the vertical size (height) of the player window.
Setting Up an HTML5 Player

Use the following procedure to edit the HTML5 player file.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed).
   - [IIS install directory]\html5
2. Right-click on the html5.html file and select Edit to open Notepad.
3. Edit the following text (see figure 9).

```
#demos .tags span:hover, #demos .tags span.selected {
    border: 1px solid #75784C;
    background: #FF7;
    color: #333521;
}
</style>
</head>
<body>
<div id="header"><a href="../index.html"><img src="../extron_logo_09.png" width="390" height="60" border="0" /></a></div>
<div id="select_head2" align="center">SME 100 streaming to Wowza Media Server and transcoded to HTTP for HTML5</div>
<div id="select_opt" align="center">
<section id="wrapper">
<article>
<video src="http://ADDIPHERE:1935/live/SME1.stream/playlist.m3u8" width="620" height="352" controls preload></video>
</article>
<script>
var video = document.querySelector('video'),
togglePlay = document.querySelector('#play'),
position = document.querySelector('#position'),
ready = false,
controls = document.querySelector('#controls'),
fullscreen = null;
addEvent(togglePlay, 'click', function () {
    if (ready) {
        video.playbackRate = 0.5;
        if (video.paused) {
            if (video.ended) video.currentTime = 0;
            video.play();
            
            Figure 9. html5.html Notepad Document

a. Replace the ADDIPHERE characters in the string (outlined in red), with the IP address of the computer / server with Wowza Media Server installed.

b. If necessary, change the SME1.stream text (outlined in red; this entry is case sensitive) with the appropriate stream file name created using steps 1 through 4 of the "Wowza Set Up and Configuration" section on page 3.

c. If necessary, change the video player window size by editing the values outlined in green. The first value represents the horizontal size (width) of the player window. The second value represents the vertical size (height) of the player window.

4. From the File menu, select Save to save the html5.html file.
Setting Up Silverlight® Player

Use the following procedure to edit the Silverlight player file.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed).
   - [IIS install directory]\silverlight

2. Right-click on the silverlight.html file and select Edit to open Notepad.

3. Edit the following text (see figure 10).

```html
else if (errorType == "RuntimeError")
{
  if (args.lineNumber != 0)
  {
    errMsg += "Line: " + args.lineNumber + "\n";
    errMsg += "Position: " + args.characterPosition + "\n";
  }
  errMsg += "MethodName: " + args.methodName + "\n";
}
throw new Error(errMsg);
</script>
</head>
<body>
<div id="header">
    <a href="../index.html"><img src="../extron_logo_09.png" width="390" height="60" border="0" /></a>
</div>
<div id="select_head2" align="center">SME 100 streaming to Wowza Media Server and transcoded to HTTP for SilverLight</div>
<div id='errorLocation' style="font-size: small;color: Gray;"></div>
<div id="silverlightControlHost">
    <object data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="510" height="525">
        <param name="source" value="ClientBin/LiveSmoothStreaming.xap" />
        <param name="onerror" value="onSilverlightError" />
        <param name="background" value="black" />
        <param name="minRuntimeVersion" value="4.0.50401.0" />
        <param name="autoUpgrade" value="true" />
        <a href="http://go.microsoft.com/fwlink/?LinkID=149156&v=4.0.50401.0" style="text-decoration: none;">
            <img src="http://go.microsoft.com/fwlink/?LinkID=161376" alt="Get Microsoft Silverlight" style="border-style: none;" />
        </a>
    </object>
</div>
</div>
</body>
</html>
```

Figure 10. Silverlight.html Notepad Document

a. Replace the ADDIPHERE characters (outlined in red) with the IP address of the computer / server with Wowza Media Server installed.

b. If necessary, change the SME1.stream text (outlined in red; this entry is case sensitive) with the appropriate stream file name created using steps 1 through 4 of the "Wowza Set Up and Configuration" section on page 3.

c. If necessary, change the video player window size by editing the values outlined in green. The first value represents the horizontal size (width) of the player window. The second value represents the vertical size (height) of the player window.

4. From the File menu, select Save to save the silverlight.html file.
Setting Up Stream Autodetection (Flash and HTML5 Players Only)

The stream autodetection file determines if a control PC (connected to the computer / server with Wowza Media Server installed) supports Flash player by placing an autodetection link on the viewer web page. If the control PC supports Flash player, the autodetection link takes the user to the Flash player page. If the control PC does not support Flash player, the autodetection link takes the user to the HTML5 player page.

Use the following procedure to edit the stream autodetection file.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed).
   - [IIS install directory]\autodetect
2. Right-click on the auto.html file and select Edit to open Notepad.
3. Edit the following text (see figure 11).

   ```javascript
   <SCRIPT LANGUAGE=JavaScript1.1>
   <!--
   var MM_contentVersion = 6;
   var plugin = (navigator.mimeTypes && navigator.mimeTypes["application/x-shockwave-flash"] ? navigator.mimeTypes["application/x-shockwave-flash"].enabledPlugin : 0;
   if ( plugin ) {
     var words = navigator.plugins["Shockwave Flash"].description.split(" ");
     for (var i = 0; i < words.length; ++i)
     {
       if (isNaN(parseInt(words[i])))
       continue;
       var MM_PluginVersion = words[i] ;
     }
     var MM_FlashCanPlay = MM_PluginVersion >= MM_contentVersion;
   } else if (navigator.userAgent && navigator.userAgent.indexOf("MSIE")>=0
     && (navigator.appVersion.indexOf("Win") != -1)) {
     document.write('<SCRIPT LANGUAGE=VBScript>
    on error resume next
    MM_FlashCanPlay = ( IsObject(CreateObject("ShockwaveFlash.ShockwaveFlash." & MM_contentVersion)))
    </SCRIPT>
    
    if ( MM_FlashCanPlay ) {
      window.location.replace("http://ADDIPHERE/flash/flash.html");
    } else{
      window.location.replace("http://ADDIPHERE/html5/html5.html");
    }
    //-->  
   </SCRIPT>
   -->
   </SCRIPT>
   ```

   Figure 11. Auto.html Notepad Document

   a. Replace the ADDIPHERE text (outlined in red) with the IP address of the computer / server with Wowza Media Server installed. There are two places that need to be edited.

4. From the File menu, select Save to save the auto.html file.
Setting Up the Index Page (Main Page)

The index page file is what the user will see on a control PC when it is connected to the Wowza Media Server.

Use the following procedure to edit the index page file.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed):
   - [IIS install directory]

2. Right-click on the index.html file and select **Edit** to open Notepad (see figure 12).

   ![Index.html Notepad Document]

   **Figure 12.** Index.html Notepad Document

3. Replace the **ADDIPHERE** characters (outlined in red) with the IP address of the computer / server with Wowza Media Server installed. (see figure 12).

4. From the **File** menu, select **Save** to save the index.html file. If necessary, the index file can be modified further using HTML code. This allows users to create a unique Wowza Media Server web page.
Configuring Wowza Stream Manager

The following procedure configures Wowza Stream Manager to start and stop streams.

1. Create a user name and password using the following steps.
   a. Navigate to the following location (on the computer / server with Wowza Media Server installed).
      • [Wowza install directory]\conf
   b. Right-click on the Admin.Password file and select Edit to open Notepad.
   c. Use the following format to modify the user name and password in the Admin.Password file (see figure 13).
      • User name [single space] Password
      • For example, admin admin

      ![Admin.Password - Notepad](image)

      # Admin password file (format [username][space][password])
      #username password
      admin admin

   d. From the File menu, select Save to save the Admin.Password file.

2. Now that the user name and password has been set, connect to Wowza Stream Manager by opening a web browser on a control PC and entering the following into the address bar.
   • http://[Wowza Media Server PC IP address]:8086/streammanager

3. When prompted for a user name and password, enter the user name and password created in step 1 of this procedure.

4. The Wowza Stream Manager page appears (see figure 14 below). This page is used to start, stop, and restart live streams. To continue setting up the Wowza Media Server, a live stream must be started. To start a live stream, under the live/_definst_ folder, click [start receiving stream] (see figure 14).

   **NOTE:** Skip steps 4, 5, and 6 of this procedure if automatic streaming is enabled as these will already be running.

   ![Wowza Media Server 3: Stream Manager](image)

   **Figure 14. Starting a Live Stream**
5. The Start Receiving Stream window appears. In the Stream Name field, type SME1.stream (this entry is case sensitive) and click OK (see figure 15).

![Start Receiving Stream Window](image)

**Figure 15.** Specifying the Stream Name

**NOTE:** MediaCaster Type defaults to RTP and should not be changed for streaming with the SME 100.

6. A message appears that says the stream has successfully started.

**Accessing the Viewer Web Page**

Use the following procedure to access the viewer web page that will be used to select live streaming media from the Wowza Media Server.

**NOTE:** Before starting this procedure, make sure all of the previous sections have been completed.

1. Open a web browser on a control PC and enter the IP address of the computer / server (with Wowza Media Server installed) into the address bar.
   - http://[Wowza Media Server PC IP address]
   - Example: http://192.168.254.254
2. The Wowza Media Server viewer web page appears (see figure 16). Use this page to view live streams and select different video formats.

![Viewer Web Page](image)

**Figure 16.** Viewer Web Page
This section provides information about:

- Setting Up Stream Hyperlinks
- List of Ports Used for Streaming
- Opening Additional Stream Ports

### Setting Up Stream Hyperlinks

**NOTE:** The following URLs generated for each player were created using Wowza guidelines.

**Flash Real Time Messaging Protocol (RTMP) Streaming (Adobe Flash Player)**

```
[protocol-method]://[wowza-address]/[application]/[application-instance]
```

**Example:**

```
rtmp://mycompany.com/myapplication
```

<table>
<thead>
<tr>
<th>Argument</th>
<th>Entry Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>[protocol-method]</td>
<td>rtmp, rtmp (encryption), rtmp (tunneling), rtmp (encryption and tunneling), or rtmp (tunneling over SSL)</td>
</tr>
<tr>
<td>[wowza-address]</td>
<td>IP address (or domain name) and port of the Wowza Media Server (default port is 1935)</td>
</tr>
<tr>
<td>[application]</td>
<td>Application name</td>
</tr>
<tr>
<td>[application-instance]</td>
<td>Application instance name (if omitted, defaults to <em>definst</em>)</td>
</tr>
</tbody>
</table>

**Flash HTTP Streaming (Adobe Flash Player)**

```
http://[wowza-address]:port/[application]/[application-instance]/[stream-name]/manifest.f4m
```

**Example:**

```
```

<table>
<thead>
<tr>
<th>Argument</th>
<th>Entry Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>[wowza-address]:port</td>
<td>IP address (or domain name) and port of the Wowza Media Server (default port is 1935)</td>
</tr>
<tr>
<td>[application]</td>
<td>Application name</td>
</tr>
<tr>
<td>[application-instance]</td>
<td>Application instance name (if omitted, defaults to <em>definst</em>)</td>
</tr>
<tr>
<td>[stream-name]</td>
<td>Stream name with stream prefix</td>
</tr>
<tr>
<td><strong>Flash HTTP Streaming (Adobe Flash Player)</strong></td>
<td></td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>http://[wowza-address]:port/[application]/[application-instance]/[stream-name]/manifest.f4m</td>
<td>Example: <a href="http://mycompany.com:1935/myapplication/mp4:myvideo.mov/manifest.f4m">http://mycompany.com:1935/myapplication/mp4:myvideo.mov/manifest.f4m</a></td>
</tr>
</tbody>
</table>

| **NOTES:** Open Source Media Framework (OSMF) Flash players are available at the following locations on the Wowza Media Server: |
| • [Wowza install directory]/examples/SimpleVideoStreaming/clientOSMF/bin-release\SimpleOSMFPPlayer.html |
| • [Wowza install directory]/examples/LiveVideoStreaming/clientOSMF/bin-release\LiveOSMFPPlayer.html |

<table>
<thead>
<tr>
<th><strong>Apple HTTP Streaming (Cupertino streaming — iPhone®, iPad®, iPod touch®)</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>http://[wowza-address]:port/[application]/[application-instance]/[stream-name]/playlist.m3u8</td>
<td>Example: <a href="http://mycompany.com:1935/myapplication/mp4:myvideo.mov/playlist.m3u8">http://mycompany.com:1935/myapplication/mp4:myvideo.mov/playlist.m3u8</a></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Argument</strong></th>
<th><strong>Entry Examples</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>[wowza-address]:port</td>
<td>IP address (or domain name) and port of the Wowza Media Server (default port is 1935)</td>
</tr>
<tr>
<td>[application]</td>
<td>Application name</td>
</tr>
<tr>
<td>[application-instance]</td>
<td>Application instance name (if omitted, defaults to <em>definst</em>)</td>
</tr>
<tr>
<td>[stream-name]</td>
<td>Stream name with stream prefix</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Smooth Streaming (Microsoft Silverlight)</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>http://[wowza-address]:port/[application]/[application-instance]/[stream-name]/Manifest</td>
<td>Example: <a href="http://mycompany.com:1935/myapplication/mp4:myvideo.mov/Manifest">http://mycompany.com:1935/myapplication/mp4:myvideo.mov/Manifest</a></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Argument</strong></th>
<th><strong>Entry Examples</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>[wowza-address]:port</td>
<td>IP address (or domain name) and port of the Wowza Media Server (default port is 1935)</td>
</tr>
<tr>
<td>[application]</td>
<td>Application name</td>
</tr>
<tr>
<td>[application-instance]</td>
<td>Application instance name (if omitted, defaults to <em>definst</em>)</td>
</tr>
<tr>
<td>[stream-name]</td>
<td>Stream name with stream prefix</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>RTSP / RTP / MPEG-TS (QuickTime, VLC, mobile devices, set top boxes, encoders)</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>rtsp://[wowza-address]/[application]/[application-instance]/[stream-name]</td>
<td>Example: rtp://mycompany.com:1935/myapplication/mystream</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Argument</strong></th>
<th><strong>Entry Examples</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>[wowza-address]:port</td>
<td>IP address (or domain name) and port of the Wowza Media Server (default port is 1935)</td>
</tr>
<tr>
<td>[application]</td>
<td>Application name</td>
</tr>
</tbody>
</table>
**RTSP / RTP / MPEG-TS (QuickTime, VLC, mobile devices, set top boxes, encoders)**

rtsp://[wowza-address]/[application]/[application-instance]/[stream-name]

**Example:** rtsp://mycompany.com:1935/myapplication/mystream

<table>
<thead>
<tr>
<th>Argument</th>
<th>Entry Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>[application-instance]</td>
<td>Application instance name (if omitted, defaults to <em>definst</em>)</td>
</tr>
<tr>
<td>[stream-name]</td>
<td>Stream name with stream prefix</td>
</tr>
</tbody>
</table>

**List of Ports Used for Streaming**

By default, Wowza Media Server uses the following ports for streaming. These ports must be opened to enable streaming when using a firewall.

- **TCP 1935** — RTMP (all variants), RTSP, smooth streaming, and Cupertino streaming
- **UDP 6970-9999** — RTP UDP streaming
- **TCP 8084-8085** — JMX / JConsole monitoring and administration
- **TCP 8086** — HTTP administration

**NOTE:** By default, Wowza Media Server uses TCP port 1935 for all forms of streaming. See "Opening Additional Stream Ports" below for information on opening and using other ports.
Opening Additional Stream Ports

Use the following procedure to open and assign additional streaming ports.

1. Navigate to the following location (on the computer / server with Wowza Media Server installed).
   - [Wowza install directory] \ conf

2. Right-click on the VHost.xml file and select Edit to open Notepad.

```xml
<Root>
  <VHost>
    <HostPortList>
      <HostPort>
        <ProcessorCount>4</ProcessorCount>
        <IpAddress>*</IpAddress>
        <!-- Separate multiple ports with commas -->
        <!-- 80: HTTP, RTMPT -->
        <!-- 554: RTSP -->
        <Port>554</Port>
        <SocketConfiguration>
          ...
        </SocketConfiguration>
      </HostPort>
    </HostPortList>
  </VHost>
</Root>
```

**Figure 17. Open Additional Stream Ports**

3. Edit the port numbers for the line of code as shown (see figure 17). Change only the numbers outlined in red. If necessary, use a comma to separate multiple port numbers.

Common streaming ports used with Wowza Media Server are listed below.

- **TCP 80** — RTMPT, smooth streaming, and Cupertino streaming
- **TCP 443** — RTMPS
- **TCP 554** — RTSP

**NOTE:** Be sure that the ports being opened are not running other applications or server software.

4. From the **File** menu, select **Save** to save the VHost.xml file.
<table>
<thead>
<tr>
<th>Region</th>
<th>Phone Number</th>
<th>Fax Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extron USA</td>
<td>+1.800.633.9876</td>
<td>+1.714.491.1517</td>
</tr>
<tr>
<td>- West</td>
<td>+1.714.491.1500</td>
<td></td>
</tr>
<tr>
<td>- East</td>
<td>+1.919.850.1000</td>
<td>+1.919.850.1001</td>
</tr>
<tr>
<td>Extron Europe</td>
<td>+400.3987.6673</td>
<td>+31.33.453.4040</td>
</tr>
<tr>
<td>- Inside USA/Canada Only</td>
<td>+800.3987.6673</td>
<td>+31.33.453.4050 FAX</td>
</tr>
<tr>
<td>- Inside Europe Only</td>
<td>+81.3.3511.7655</td>
<td>+31.33.453.4040 FAX</td>
</tr>
<tr>
<td>Extron Asia</td>
<td>+65.6383.4400</td>
<td>+86.21.3760.1568</td>
</tr>
<tr>
<td>- Inside Asia Only</td>
<td>+65.6383.4664</td>
<td>+86.21.3760.1566 FAX</td>
</tr>
<tr>
<td>Extron Japan</td>
<td>+81.3.3511.7655</td>
<td>+82.3.3444.1571</td>
</tr>
<tr>
<td>- Inside China Only</td>
<td>+82.3.3444.1575</td>
<td>+971.4.2991880 FAX</td>
</tr>
<tr>
<td>Extron China</td>
<td>+800.3987.6676</td>
<td>+971.4.2991880 FAX</td>
</tr>
<tr>
<td>Extron Middle East</td>
<td>+971.4.2991880</td>
<td>+971.4.2991880 FAX</td>
</tr>
<tr>
<td>Extron Korea</td>
<td>+82.3.3444.1571</td>
<td>+971.4.2991880 FAX</td>
</tr>
<tr>
<td>Extron India</td>
<td>+91.80.3055.3777</td>
<td>+971.4.2991880 FAX</td>
</tr>
<tr>
<td>- Inside India Only</td>
<td>+91.80.3055.3777</td>
<td>+971.4.2991880 FAX</td>
</tr>
<tr>
<td>Extron Middle East</td>
<td>+91.80.3055.3777</td>
<td>+971.4.2991880 FAX</td>
</tr>
</tbody>
</table>

© 2013 Extron Electronics  All rights reserved. www.extron.com